
สถิติพื้นฐาน
(Basic statistic)

วราภรณ์ เนตรพราว
นักวิชาการสถิติปฏิบัติการ
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ประเภทของสถิติ 
1. สถิติพรรณนา (Descriptive Statistics) เป็นสถิติที่ใช้อธิบายคุณลักษณะของ
สิ่งที่ต้องการศึกษากลุ่มใดกลุ่มหนึ่ง ไม่สามารถอ้างอิงไปยังกลุ่มอื่นๆ ได้ 
สถิติที่อยู่ในประเภทนี้ เช่น ค่าเฉลี่ย(Mean) ค่ามัธยฐาน(Median) ส่วนเบี่ยงเบน
มาตรฐาน (SD) ค่าสูงสุด(Max) ค่าต่่าสุด(Min) พิสัยระหว่างควอไทล์ (IQR)ฯลฯ
2. สถิติอ้างอิง (Inferential statistics) เป็นสถิติที่ใช้อธิบายคุณลักษณะของสิ่งที่
ต้องการศึกษากลุ่มใดกลุ่มหนึ่งหรือหลายกลุ่ม แล้วสามารถอ้างอิงไปยังกลุ่ม
ประชากรได้
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สถิติพรรณนา (Descriptive Statistics)

ตัวแปรเชิงคุณภาพ จ่านวน (n) ,ร้อยละ (%)

ตัวแปรเชิงปริมาณ ค่าเฉลี่ย (Mean) ,ส่วนเบี่ยงเบนมาตรฐาน (SD)
ค่ามัธยฐาน (Median) ,พิสัยระหว่างควอไทล์ (IQR)
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หน้าต่างโปรแกรม SPSS

ชื่อตัวแปร

ชนิดตัวแปรที่ใช้บ่อยๆ
- Numeric ลักษณะข้อมูลเป็นตัวเลข
- String ลักษณะข้อมูลเป็นข้อความ 

จ านวนจุดทศนิยม Coding ตัวแปร

หน้าต่าง Variable View หน้าต่าง Data View 4



วิธีการน าเข้าข้อมูลจาก Excel เข้าโปรแกรม SPSS

1 2 3

ใช้ค่าสั่ง File > Import Data > Excel เลือกที่อยู่ไฟล์ Excel ที่ต้องการน่าเข้า เลือก  ตามตัวอย่าง กด OK
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ตัวอย่างการหาค่าจ านวน (n) ,ร้อยละ (%) จากโปรแกรม
ค่าสั่งในโปรแกรม 
1. คลิกที่ Analyze > Descriptive Statistics > Frequencies
2. ปรากฏหน้าต่าง Frequencies > ช่อง Variable(s) : เลือกตัวแปรที่ต้องการตรวจสอบ (สามารถเลือกได้หลายตัวแปร)

ในตัวอย่างนี้คือตัวแปร Age_group

หน้าต่างค่าสั่ง หน้าต่าง Output
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กรณี ไม่มีค่า Missing มีค่า Missing



ตัวอย่างการหาค่า Mean ,SD ,Median ,IQR จากโปรแกรม
ใช้ค่าสั่ง Analyze > Descriptive Statistics > Frequencies

เอาเครื่องหมาย
 ออก 

คลิกเมนู Statistics

1 2

3

4

Hint: IQR ค่านวณได้จาก 
Percentiles 75 ลบ Percentiles 25
จากตัวอย่าง IQR = 34-25 = 9
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สถิติอ้างอิง (Inferential statistics)

Parametric
t-test (Paired)
t-test (Independent)
ANOVA

มีข้อตกลงเบื้องต้น ไม่มขี้อตกลงเบื้องต้น
Non - Parametric

Wilcoxon Signed Ranks Test
Mann-Whitney U test
Kruskal-Wallis H test

ข้อตกลงเบื้องต้นข้อที่ 1 ข้อมูลมีการแจกแจงเป็นแบบโค้งปกติ
H0 : ข้อมูลมีการแจกแจงเป็นแบบโค้งปกติ
H1 : ข้อมูลไม่ได้มีการแจกแจงเป็นแบบโค้งปกติ
ปฏิเสธ H0 ที่ p-value < 0.05

ข้อตกลงเบื้องต้นข้อที่ 2 ความแปรปรวนในแต่กลุ่มไม่แตกต่างกัน
H0 : ความแปรปรวนในแต่กลุ่มไม่แตกต่างกัน
H1 : ความแปรปรวนในแต่กลุ่มแตกต่างกัน
ปฏิเสธ H0  ที่ p-value < 0.05



ข้อตกลงเบื้องต้น
ข้อมูลมีการแจกแจงเป็นแบบโค้งปกติ
H0 : ข้อมูลมีการแจกแจงเป็นแบบโค้งปกติ
H1 : ข้อมูลไม่ได้มีการแจกแจงเป็นแบบโค้งปกติ
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ใช้ค่าสั่ง Analyze > Descriptive Statistics > Explore

1 2

1

2 3

หน้าต่างค าสั่ง

หน้าต่าง output

ปฏิเสธ H0 ที่ p-value < 0.05
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การวิเคราะห์ค่าเฉลี่ยกลุ่มตัวอย่างกลุ่มเดียว
(One- Sample T-Test)
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การวิเคราะห์ One- Sample T-Test เป็นการทดสอบกลุ่มตัวอย่างกลุ่มเดียวว่า ผลการทดสอบนั้น
เป็นไปตามเกณฑ์ที่ก่าหนดหรือไม่ 

การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : อายุเฉลี่ยของผูป้่วย เท่ากับ 50 ปี
H1 : อายุเฉลี่ยของผู้ป่วย ไม่เท่ากับ 50 ปี

ใช้ค่าสั่ง Analyze > Compare Means >One-Sample T Test



วิธีการแปลผล One- Sample T-Test จากโปรแกรม
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หน้าต่าง Output จากโปรแกรม

การทดสอบสมมติฐาน
H0 : อายุเฉลี่ยของผู้ป่วย เท่ากับ 50 ปี
H1 : อายุเฉลี่ยของผู้ป่วย ไม่เท่ากับ 50 ปี
ผลการทดสอบ : ค่า p-value = <0.001 ซึ่งมีค่าน้อยกว่า 
ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงปฏิเสธ H0 ดังนั้น 
อายุเฉลี่ยของผู้ป่วยไม่เท่ากับ 50 ปี อย่างมีนัยส่าคัญทางสถิติ

ปฏิเสธ H0 ที่ p-value < 0.05

แปลผลจาก Output จากโปรแกรม



การวิเคราะห์ค่าเฉลี่ยกลุ่มตัวอย่าง  2 กลุ่มอิสระจากกัน 
(Independent Sample T-Test)
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การวิเคราะห์มีวัตถุประสงค์ของการทดสอบเพื่อทดสอบว่า 2 กลุ่มอิสระจากกันนั้น 
มีค่าเฉล่ียแตกต่างกันหรือไม่ โดยมีข้อตกลงเบื้องต้น คือ ข้อมูลทั้งสองกลุ่มต้องมีการแจกแจงเป็น
แบบโค้งปกติ
ตัวอย่างวัตถุประสงค์ที่ใช้สถิติ Independent Sample T-Test เช่น
- ต้องการเปรียบเทียบอายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายแตกต่างกันหรือไม่
- ต้องการเปรียบเทียบค่า BMI เฉลี่ยในกลุ่มควบคุมและกลุ่มทดลองแตกต่างกันหรือไม่



ตัวอย่างการใช้ Independent Sample T-Test จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : อายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายไม่แตกต่างกัน
H1 : อายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายแตกต่างกัน

ใช้ค่าสั่ง Analyze > Compare Means >Independent-Sample T Test

ระบุเลข Coding
จากข้อมูลดิบ

ตัวแปรอายุของทั้งเพศหญิงและเพศชายมีการแจกแจงเป็นแบบโค้งปกติ

Male Female

คลิก

1

2



วิธีการแปลผล Independent Sample T-Test จากโปรแกรม
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หน้าต่าง Output จากโปรแกรม

การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ                               
H0 : อายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายไม่แตกต่างกัน
H1 : อายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายแตกต่างกัน

แปลผลจาก Output จากโปรแกรม
ผลการทดสอบ : ค่า p-value = 0.349 ซึ่งมีค่ามากกว่า
ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงยอมรับ H0 ดังนั้น 
อายุเฉลี่ยในกลุ่มเพศหญิงและเพศชายไม่แตกต่างกัน
อย่างมีนัยส่าคัญทางสถิติ

การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ                               
H0 : ความแปรปรวนในแต่กลุ่มไม่แตกต่างกัน
H1 :ความแปรปรวนในแต่กลุ่มแตกต่างกัน
ปฏิเสธ H0 ที่ p-value < 0.05 ในที่นี้ p>0.05 จึงยอมรับH0
แสดงว่าความแปรปรวนในแต่กลุ่มไม่แตกต่างกัน 

ปฏิเสธ H0 ที่ p-value < 0.05



การวิเคราะห์ค่าเฉลี่ยกลุ่มตัวอย่าง  2 กลุ่มไม่อิสระจากกัน 
(Dependent Sample T-Test or Paired T-Test)

การวิเคราะห์ค่าเฉลี่ยของกลุ่มตัวอย่าง 2 กลุ่ม เป็นการทดสอบซ้่ากับกลุ่มตัวอย่างเดิม 
วัดจากกลุ่มตัวอย่าง 2 ครั้ง (pretest และ posttest) โดยมีข้อตกลงเบื้องต้น คือ ข้อมูลต้องมีการ
แจกแจงเป็นแบบโค้งปกติ
ตัวอย่างวัตถุประสงค์ที่ใช้สถิติ Paired T-Test เช่น
- ต้องการเปรียบเทียบปริมาณน่้านมเฉลี่ยก่อนและหลังเข้ารบัโปรแกรมนวดกระตุ้นน้่านมว่า

แตกต่างกันหรือไม่
- ต้องการทดสอบค่า BMI เฉลี่ยก่อนและหลังเข้ารับโปรแกรมออกกา่ลังกายว่าแตกต่างกัน

หรือไม่
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ตัวอย่างการใช้ Paired T-Test จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : ปริมาณน้่านมเฉลี่ยก่อนและหลังได้รับโปรแกรมไม่แตกต่างกัน
H1 : ปริมาณน้่านมเฉลี่ยก่อนและหลังได้รับโปรแกรมแตกต่างกัน

ตัวแปรปริมาณน้่านมทั้งก่อนและหลังมีการแจกแจงเป็นแบบโค้งปกติ

Before After

ใช้ค่าสั่ง Analyze > Compare Means > Paired-Sample T Test

ใส่ตัวแปร After ในช่อง Variable1
ใส่ตัวแปร Before ในช่อง Variable2
กด OK



วิธีการแปลผล Paired T-Test จากโปรแกรม
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หน้าต่าง Output จากโปรแกรม

การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : ปริมาณน้่านมเฉลี่ยก่อนและหลังได้รับโปรแกรมไม่แตกต่างกัน
H1 : ปริมาณน้่านมเฉลี่ยก่อนและหลังได้รับโปรแกรมแตกต่างกัน

แปลผลจาก Output จากโปรแกรม
ผลการทดสอบ : ค่า p-value = <0.001 ซึ่งมีค่าน้อยกว่า
ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงปฏิเสธ H0 ดังนั้น 
ปริมาณน้่านมเฉลี่ยก่อนและหลังได้รับโปรแกรมแตกต่างกัน
อย่างมีนัยส่าคัญทางสถิติ

ปฏิเสธ H0 ที่ p-value < 0.05



การวิเคราะห์ค่าเฉลี่ยของกลุ่มตัวอย่าง มากกว่า 2 กลุ่ม
(One-way ANOVA)
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การวิเคราะห์ One-way ANOVA เป็นการวิเคราะห์ความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่างมากกว่า 
2 กลุ่ม ที่มีตัวแปรอิสระ 1 ตัวแปร และเป็นตัวแปรเชิงกลุ่ม ส่วนตัวแปรตามนั้นเป็นตัวแปรปริมาณ
โดยมีข้อตกลงเบื้องต้น 2 ข้อ คือ ข้อมูลทุกกลุ่มต้องมีการแจกแจงเป็นแบบโค้งปกติ และ 
ความแปรปรวนในแต่ละกลุ่มไม่แตกต่างกัน
ตัวอย่างวัตถุประสงค์ที่ใช้สถติิ One-way ANOVA เช่น
- ต้องการเปรียบเทียบปริมาณน่้านมเฉลี่ยที่ได้รับวิธีนวดกระตุ้นน่้านมทั้ง 3 วิธี ว่าแตกต่างกันหรือไม่
- ต้องการเปรียบเทียบคะแนนเฉลี่ยที่ได้รับการสอนทั้ง 3 วิธี ว่าแตกต่างกันหรือไม่



ตัวอย่างการใช้ One-way ANOVA จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : อายุเฉลี่ยของทั้ง 3 วิธี ไม่แตกต่างกัน
H1 : อายุเฉลี่ยแตกต่างกันอย่างน้อย 1 คู่

วิธีที่1 วิธีที่2 วิธีที่3

ตัวแปรอายุของทั้ง 3 วิธีมีการแจกแจงเป็นแบบโค้งปกติ

ใช้ค่าสั่ง Analyze > Compare Means > One- Way ANOVA

1 2 3



วิธีการแปลผล One-way ANOVA จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานท่ีทดสอบคือ 
H0 : อายุเฉลี่ยของทั้ง 3 วิธี ไม่แตกต่างกัน
H1 : อายุเฉลี่ยแตกต่างกันอย่างน้อย 1 คู่

แปลผลจาก Output จากโปรแกรม
ผลการทดสอบ : ค่า p-value = 0.002 ซึ่งมีค่าน้อยกว่า ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงปฏิเสธ H0 ดังนั้นอายุเฉลี่ยแตกต่างกัน
อย่างน้อย 1 คู่ อย่างมีนัยส่าคัญทางสถิติ จึงไปท่าการเปรียบเทียบเชิงพหุ (Multiple comparisons) ต่อไป  

ปฏิเสธ H0 ที่ p-value < 0.05



วิธีการแปลผล Multiple comparisons จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : อายุเฉลี่ยกลุ่ม i และ j ไม่แตกต่างกัน 
H1 : อายุเฉลี่ยกลุ่ม i และ j แตกต่างกัน 
โดยที่  i = 1,2,3 และ j = 1,2,3
แปลผลจาก Output จากโปรแกรม
- อายุเฉลี่ยกลุ่ม 1 และ 3 แตกต่างกัน
- อายุเฉลี่ยกลุ่ม 2 และ 3 แตกต่างกัน
สรุปได้ว่าอายุเฉลี่ยกลุ่ม 3 แตกต่างจากกลุ่มอื่น
อย่างมีนัยส่าคัญทางสถิติ

ปฏิเสธ H0 ที่ p-value < 0.05



การวิเคราะห์ความสัมพันธ์ของข้อมูลเชิงคุณภาพ
(Pearson Chi-square)

วิธีการวิเคราะห์ Pearson Chi-square เป็นการเปรียบเทียบความสัมพันธ์
ระหว่างตัวแปรเชิงคุณภาพ 2 ตัวแปร
- ตัวแปรตาม และ ตัวแปรอิสระ เป็นระดับ Nominal เช่น เพศ 

หรือ ระดับ Ordinal เช่นระดับการศึกษา
ตัวอย่างวัตถุประสงค์ที่ใช้สถิติ Pearson Chi-square เช่น
- เพศมีความสัมพันธ์กับการเป็นโรคหรือไม่
- กลุ่มผู้ป่วยเบาหวานมีความสัมพันธ์กับภาวะความดันโลหิตสูงหรือไม่
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ตัวอย่างการใช้ Pearson Chi-square จากโปรแกรม
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2 3

การทดสอบก่าหนดสมมติฐานที่ทดสอบคือ 
H0 : เพศไม่มีความสัมพันธ์กับการเป็นโรค
H1 : เพศมีความสัมพันธ์กับการเป็นโรค

ใช้ค่าสั่ง Analyze > Descriptive Statistics >Crosstabs

1



วิธีการแปลผล Pearson Chi-square กรณี ตาราง 2*2 จากโปรแกรม
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การทดสอบก่าหนดสมมติฐานท่ีทดสอบคือ 
H0 : เพศไม่มีความสัมพันธ์กับการเป็นโรค
H1 : เพศมีความสัมพันธ์กับการเป็นโรค

แปลผลจาก Output จากโปรแกรม
ผลการทดสอบ : ค่า p-value = <0.001 ซึ่งมีค่าน้อยกว่า 
ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงปฏิเสธ H0 ดังนั้น
เพศมีความสัมพันธ์กับการเป็นโรค โดยที่เพศหญิงมีโอกาสเสี่ยง
เป็นโรคมากกว่าเพศชาย 7.37 เท่าอย่างมีนัยส่าคัญทางสถิติ

ปฏิเสธ H0 ที่ p-value < 0.05



วิธีการยุบ cell กรณี มี cell ใด cell หนึ่งมีค่าเท่ากับ 0 ในตาราง ROW*COL

***กรณียุบ cell จะสามารถยุบได้ในระดับที่ใกล้เคียงกันเท่านั้น 
เช่น ระดับ Obese1 และ Obese2 สามารถปรับเป็นระดับ Obese 1 ขึ้นไปได้ 
แต่ ถ้ายกตัวอย่างกรณี ระดับ Underweight มี cell เท่ากับ 0 จะไม่สามารถ ยุบ cell รวมกับระดับอื่นได้ เนื่องจากลักษณะ
ของผู้ป่วยอยู่ในระดับแตกต่างจากผู้ป่วยกลุ่มอื่นๆ

ก่อนยุบ cell หลังยุบ cell
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วิธีการแปลผล Pearson Chi-square กรณี ตาราง ROW*COL จากโปรแกรม

การทดสอบก่าหนดสมมติฐานท่ีทดสอบคือ 
H0 : กลุ่ม BMI ไม่มีความสัมพันธ์กับการเป็นโรค
H1 : กลุ่ม BMI มีความสัมพันธ์กับการเป็นโรค

ปฏิเสธ H0 ที่ p-value < 0.05

แปลผลจาก Output จากโปรแกรม
ผลการทดสอบ : ค่า p-value = 0.740 ซึ่งมีค่ามากกว่า 
ระดับนัยส่าคัญที่ก่าหนดคือ 0.05 จึงไม่สามารถปฏิเสธ H0 
ดังนั้น กลุ่ม BMI ไม่มีความสัมพันธ์กับการเป็นโรค 
อย่างมีนัยส่าคัญทางสถิติ 
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ชนิดของตัวแปร ลักษณะตัวอย่าง Parametric Non Parametric
ตัวแปรตามเป็นตัวแปรเชิงปริมาณ 1 กลุ่มตัวอย่าง One-sample T Test Sign test

ตัวแปรตามเป็นตัวแปรเชิงปริมาณ
ตัวแปรต้นเป็นตัวแปรเชิงคุณภาพ

2 กลุ่มตัวอย่างอิสระกัน Independent T test Wilcoxon rank sum 
or Mann- Whitney U test

ตัวแปรตามเป็นตัวแปรเชิงปริมาณ
ตัวแปรต้นเป็นตัวแปรเชิงคุณภาพ

2 กลุ่มตัวอย่างไม่อิสระกัน Dependent T test 
or Paired T test

Wilcoxon sign rank test

ตัวแปรตามเป็นตัวแปรเชิงปริมาณ
ตัวแปรต้นเป็นตัวแปรเชิงคุณภาพ

>2 กลุ่มตัวอย่างอิสระกัน One – way ANOVA Kruskal-Wallis test

ตัวแปรตามเป็นตัวแปรเชิงคุณภาพ
ตัวแปรต้นเป็นตัวแปรเชิงคุณภาพ

2 กลุ่มตัวอย่างอิสระกัน Chi-square test 
or Fisher’s exact test

ตารางสรุปการใช้สถิติเบื้องต้น
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Thank you
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